Back to overview
Downtime

Ora is down

Jan 14, 2025 at 5:37pm UTC
Affected services
ora

Updated
Jan 23, 2025 at 2:41pm UTC

will be resolved soon

Created
Jan 14, 2025 at 5:37pm UTC

team working on it